SAP Knowledge Base Article - Public

3606733 - Error: "Data purge process failed for purge object type = DRTMONBMasterDataObjectType" during Onboarding 1.0 purge

Symptom

When attempting to perform a data purge for Onboarding 1.0, the following error appears in the Purge Request Monitor: 

Data purge process failed for purge object type = DRTMONBMasterDataObjectType. Please check for any data inconsistency in your system or contact customer support.

The DRTM Master Data Purge job shows a status of Completed with Errors.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Navigate to Admin Center > Purge Request Monitor.
  2. Locate the DRTM Master Data Purge job related to Onboarding 1.0.
  3. Note that the job status is Completed with Errors.
  4. Review the error log, which displays: Data purge process failed for purge object type = DRTMONBMasterDataObjectType. Please check for any data inconsistency in your system or contact customer support.

Cause

This error can occur if there is a misconfiguration in the BizX system connection, specifically, an inconsistency between the company ID configured in Provisioning and the Account ID mapping in Super Admin.

For example:

  • In Provisioning: Company ID id is saptest1 and the Account ID connected to it is saptest1.
  • HoweverIn Super Admin the Account ID saptest1 is NOT mapped to the same company ID saptest1, it is in fact mapped to a different Company ID: saptest2

This mismatch prevents the purge process from correctly identifying and purging Onboarding 1.0 data. The connection must be unique, no other company or account ID can be shared.

Resolution

Check that the BizX connection is correctly set up:

  1. In Provisioning, confirm the Company ID is correctly linked to the Account ID.
  2. In Super Admin, make sure the Account ID is mapped to the same Company ID as in Provisioning.
  3. If they don’t match, update the settings so that the Company ID and Account ID are correctly linked in both places.

If you're not sure how to check or fix these settings, please contact your implementation partner for better understanding it.

Additionally: Customers can face such issue after the upgrade of DRTM Onboarding 1.0. If that's the case and customer is no longer able to address it by doing the BizX connection (i.e. SuccessFactors Onboarding 1.0 is no longer being used), the upgrade can only be rolled back in our back end.

Team, please raise a case with the component LOD-SF-OBD-GDP confirming this is the case and providing:

  • Affected Company ID
  • Support Access
  • Approval to run the script in our back end to "roll back the DRTM Onboarding 1.0 upgrade".

See Also

3066913 - Establishing a Connection Between BizX Provisioning and Onboarding SuperAdmin - Onboarding 1.0 - SAP for Me

Keywords

Exception while sending KMS Webservice get request, DRTMONBMasterDataObjectType, Data purge process failed for purge object type, purge, onboarding, 1.0, failed, fail, report, completed with errors, DRTM, Master, Data Purge, OBD, upgrade, DRTM Onboarding 1.0 , KBA , LOD-SF-OBD-GDP , General Data Protection Regulation (GDPR) , Problem

Product

SAP SuccessFactors Onboarding all versions