SAP Knowledge Base Article - Public

3606745 - Primary record is not displayed at the top of Emergency Contact

Symptom

  • When a new primary record is added to the Emergency Contact, the record appears in the "Details" section instead of at the top of the portlet;

    "All the images from this instance are from our internal test instances, any resemblance with real environments are mere coincidence".

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Navigate to an employee profile.
  2. Add a new contact as the primary in the Emergency Contact section.



  3. Observe that the new primary contact appears in Details section and not at the top of the Emergency Contact portlet.

Cause

This is an expected behavior.

Resolution

  • The Emergency Contact Information portlet is not effective dated. If you change the primary contact the system will keep the same order from the first record with "Is Primary: Yes."
  • Only the Emergency Contact that is first time added will have primary record to the top. The next records that are added later will keep its order.

See Also

Keywords

SAP SuccessFactors, Employee Central, Primary Record, Emergency Contact, top, Details, Portlet, primary yes , KBA , LOD-SF-EC-EDP-ECO , Emergency Contact Information Import , Problem

Product

SAP SuccessFactors Employee Central all versions