SAP Knowledge Base Article - Public

3606805 - Data Deletion Failure for Private Customer – Form of Address Missing Error in SAP Cloud for Customer

Symptom

  • An issue arises during the data removal process for a private customer.
  • A single deletion run for this customer fails according to the data deletion log.
  • The application log displays an error message stating "Form of Address is missing".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Login in Cloud for Customer.
  2. Navigate to Data Protection and Privacy Work Center.
  3. Proceed to Personal Data Removal.
  4. Search for Private Account ID.
  5. Initiate a data removal run using the "delete" button.
  6. Start a removal run.
  7. Go to Administer Data Removal Runs and wait for the run to end.
  8. Open the Application Log Detailed View of the failed run and go to Results.
  9. The error message is "Form of Address missing"

Cause

Database inconsistency.

Resolution

  1. Check the mentioned private account ID and edit it.
  2. Make a dummy change in the title field, as example changing the title from Mr. to Ms. and click the save button.
  3. Return the changes to let it as previous state and save again.
  4. Try to proceed with data removal again.
  5. In case it does not resolve the issue, please create a case to AP-RC-ILM support team.

See Also

Keywords

Data Deletion, Private Customer, Data Removal, Form of Address is Missing, Error, SAP Cloud for Customer, Information Lifecycle Management. , KBA , AP-RC-ILM , ByD,C4C,Travel: Information Lifecycle Management , Problem

Product

SAP Business ByDesign all versions