Symptom
After b2505 release, in Picklist Center, admin can not see picklist versions any more by clicking on the picklist code. However, admin could still see the current picklist version by clicking on the latest version date.
Environment
SAP SuccessFactors HCM Suite b2505
Reproducing the Issue
- Navigate to Picklist Center
- Click on the picklist code and it is shown as "No data available" or "No data available. Try adjust the filter settings"
Cause
The API used to retrieve data is now containing a filter of "lastModifiedByNav/status ne 'z' ".
If the user who was the last update user of that Picklist was purged from the system, then no data will return in the API response.
Resolution
Our Engineering team has fixed the issue.
The patch will be deployed on 01-Jul-25 for Preview and 03-Jul-25 in Production.
Keywords
SuccessFactors, Picklist version, Picklist Center, not visible, No data available, No data available. Try adjust the filter settings, last update user, purged, KI2505, MDF-91163 , KBA , LOD-SF-PLT-PCK , Picklist Management Issue , Known Error