SAP Knowledge Base Article - Public

3607157 - Recipient(s) has not received Outbound Email from C4C Ticket

Symptom

Recipient(s) has not received Outbound Email from C4C Ticket when there is an invalid e-mail.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center
  2. Go to the Tickets view
  3. Open a ticket
  4. Go to the Timeline / Interactions tab
  5. Send an e-mail including a valid e-mail address and an invalid e-mail address (e.g. abcd@abcd *This is just a random invalid e-mail address) in To or CC field

Result: The recipient with the correct e-mail address does not receive the e-mail.

Cause

  • There are multiple reasons as to why an outbound E-Mail may not be delivered to the Recipient such as incorrect Recipient address or Invalid Content in E-Mail body as examples.
  • Depending on the type of invalid e-mail, e-mails are delivered to a recipient even when there is an invalid e-mail in To or CC field.

Examples

  • abcd@abcd => Recipient does not receive e-mail as described on this KBA.
  • abcd@abcd.c => Recipient receives e-mail

These different behaviours occur due to e-mail processing in C4C, at the email delivery server level. When an email address contains a non-resolvable domain (abcd@abcd.c), the delivery is handled at an individual recipient level and results in a bounce message for that address, while emails are delivered successfully to other valid recipients. However, when an email address is missing the dot in the domain portion(abcd@abcd), the delivery fails at the message level and the error message is returned during email transfer resulting in no delivery to any recipients included in the same send attempt.

Resolution

Outbound E-Mail Monitoring in C4C only tracks failures that occur within C4C before the email is sent (Example: abcd@abcd). If the email is sent but then bounces back from the recipient's mail server (Example: abcd@abcd.c), this is recorded as an incoming error on the ticket, not as an outbound error, because C4C considers the message successfully sent. Therefore, bounce errors from recipient servers aren’t shown in Outbound Monitoring—only internal C4C sending failures are.

Keywords

Recipient, Backend, Delivered, Address , KBA , LOD-CRM-SC-EML , Email , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications 2502