Symptom
Technical users are not shown in the "Changed by" table in ticket attachments. However they are shown in the "Interaction Attachments" table.
Environment
SAP Cloud for Customer
Reproducing the Issue
- GO to the work center Service, view Tickets.
- Open the respective ticket.
- Go to the Attachments tab.
- In the first "Attachments" table, check the "Changed by" column. It's empty, because the changes were made by a technical user. (You can confirm this in the "Changes" tab).
Cause
The Attachment table is technical component that is reused by many objects, e.g. sales quotes, opportunity, ticket, etc. The "Changed by" cannot reflect technical users, and changes cannot be done without causing an impact on the various objects where this is used.
Resolution
In order to see the person or user who last changed the attachment, please make use of the "Changes" tab of the ticket.
Keywords
ticket, attachments, changed by, change user, technical user, missing user details, column , KBA , LOD-CRM-SRP , Service Request Processing , Product Enhancement