SAP Knowledge Base Article - Public

3607378 - C4A_AGENT folder is not available after tomcat restart.

Symptom

C4A_AGENT folder is not extracted after tomcat restart under /opt/tomcat/webapps

Environment

  • Open JDK 
  • C4A_AGENT 

Reproducing the Issue

  1. Stop Tomcat
  2. Delete the folder \Apache Software Foundation\Tomcat 7.0\webapps\C4A_AGENT\ and any subfolders and files.
  3. Delete the folder \Apache Software Foundation\Tomcat 7.0\work with temporary files
  4. Unzip the downloaded file and rename the WAR file to C4A_AGENT.war.
  5. Extract the package and copy the file C4A_AGENT.war to your Tomcat directory.
  6. The Extracted package is not visible
  7. Restart the Tomcat application server for the settings to take effect.
  8. The Extracted package is still not visible

Cause

Catalina logs show that there is no space left in desk to save the extracted C4A_Agent folder in the directory

Resolution

  1. Create space in directory by moving or deleting additional resources.
  2. Stop Tomcat
  3. Extract the package and copy the file C4A_AGENT.war to your Tomcat directory.
  4. The Extracted package is now visible
  5. Restart the Tomcat application server for the settings to take effect.

See Also

Keywords

C4A_Agent, Tomcat, SAC, SAP Analytics Cloud , KBA , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Problem

Product

SAP Analytics Cloud 1.0