Symptom
When users try to log in to applications an error message indicating that IdP-Initiated SSO has been disabled prevents access to their profile page.
Environment
SAP SuccessFactors Recruiting Marketing
Reproducing the Issue
- Log into SAP SuccessFactors.
- Click on the Careers link in the module dropdown.
- Use the search function to find a job.
- Select a job.
- Attempt to apply for the job or view the profile.
- Observe the error message indicating the IdP-Initiated SSO process is disabled.
Cause
The application was using IdP-initiated SSO, which had been disabled in the Identity Authentication Service (IAS).
Resolution
By default, IdP-Initiated SSO is enabled in Identity Authentication. The tenant administrator can disable the IdP-Initiated SSO process via the administration console for SAP Cloud Identity Services. Note that when IdP-Initiated SSO is disabled, users will be unable to access their profile page, disrupting functionality.
Use this procedure to enable the IdP-Initiated SSO process.
- Sign in to the administration console for SAP Cloud Identity Services.
- Navigate to Application Resources.
- Under Single-Sign-On, select IdP-Initiated SSO.
- Use the slider in the Settings section to enable it.
- It takes 2 minutes for the configuration changes to take place.
- Test the resolution by applying to the job using an incognito window or after clearing the cache.
See Also
2775459 - IdP-initiated SSO has been disabled by your system administrator
Keywords
SAP SuccessFactors, Recruiting, Internal Career Site, SSO Error, IdP-initiated SSO, Identity Authentication Service, IAS, CSB, Job Application, Profile View, Error, ics, permission , KBA , LOD-SF-RMK-ICS , Internal Career Site Builder (CSB, IAS, etc ...) , Problem