SAP Knowledge Base Article - Public

3608133 - Duplicated Sales Orders are created via the Webservice

Symptom

Sales Orders created via the webservice ManageSalesOrderIn are created more than once. 

Environment

SAP Business ByDesign

Reproducing the Issue

Go to the Sales Orders work center.

Select the Sales Orders view. 

You notice that the Sales Order created from SOAPUI via the web service are created more once.

Cause

When the Sales Order is sent from SOAPUI the payload runs for some time and the following error occurs in SOAPUI and no SOAP Response is sent: 

ERROR:java.net.SocketTimeoutException: Read timed out

Since no SOAP Response is sent, you assume that the Sales Order was not created in the Business ByDesign system and the payload is executed again in SOAPUI.

However, the Sales Order was created in the Business ByDesign system and this subsequently results in duplicate entries.

Resolution

The reason why the error in SOAPUI occurs is because the payload takes a lot of time and the Socket Timeout(ms) has zero (0) value or the time length is too limited.

 

To resolve the issue you need to extend/edit the time by performing the following steps:

  1. Go to the SoapUI application.
  2. Click the File drop down option.
  3. Click the Preferences option.
  4. Select HTTP Settings tab.
  5. Add a value for Socket Timeout(ms).
  6. Example: 600000ms which is the equivalent of 10 minutes.
  7. Click the OK button. 

Now click the play button to Submit the Request.

The error will not occur anymore and the SOAP Response is sent once the Sales Order is created.

 

See Also

KBA 2634690 - Error getting response; java.net.SocketTimeoutException: Read timed out 

Keywords

Sales Order, duplicated, duplicate, twice, multiple times, web service, SOAP UI, E-Shop, Web Shop, SocketTimeoutException, Socket Error, time out, no Response, API, ManageSalesOrderIn , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions