Symptom
In 'My Purchase Requisition - New' and 'Manage Purchase Requisitions Professional' apps, changes made to the account assignment data of a purchase requisition are not reflected in the change log.
However, these changes can be viewed in the 'Display Purchase Requisition - Advanced' app via Menu > Environment > Item Changes.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Update the cost center details for a Purchase Requisition in the 'My Purchase Requisition - New' application.
- Check the change log in the same application and observe that the changes are not reflected.
- View the changes via the 'Display Purchase Requisition - Advanced' application where the changes are displayed.
Cause
In the fiori apps 'My Purchase Requisition - New' and 'Manage Purchase Requisitions Professional' the Change Log lists the changes that have been made to the item since the time of its creation.
This concerns only change made at the item level. Any other change that is carried out further into the item facets, like account assignment data are not recorded. So where a user leaves the item
screen and makes a change it will not be shown in the change log of the fiori apps.
Resolution
To view a complete change log the user can use the 'Display Purchase Requisition - Advanced' (ME53n) app.
See Also
Keywords
Change Log, My Purchase Requisition - New, Display Purchase Requisition - Advanced, Cost Center, Missing Functionality, account assignment eban, cdpos, cdhdr. , KBA , MM-FIO-PUR-REQ-SSP , Fiori UI for Self Service Procurement , MM-FIO-PUR-REQ-PRF , Manage Purchase Requisitions – Professional , Problem