Symptom
When editing worker in Manage Workforce or via other data channels, the following error raised:
"Employee/Employment <WORKERID> is marked for archiving. Processing cancelled"
Environment
SAP S/4HANA Cloud Public Edition
Cause
The "Archiving flag" was ticked in Maintain Business User app for either Employee or Employment BP.
Resolution
The flag should be removed to perform any Worker data changes.
It can be removed by opening Maintain Business Partner, then selecting either Employee or Employment BP (the one mentioned in the error message).
Change to Edit mode, then remove the checkmark from "Archiving flag" then change back to Display mode.
Once the Draft is discarded in Manage Workforce, the changes can be performed.
Keywords
Archive, Edit, Change, Import, Update, Worker, Employee, Employment , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , CA-GTF-BUM , Business User Management , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem