Symptom
Facing Warning 'Cannot update XXX due to restrictions set by SAP or your administrator' when updating the field value
Environment
- SAP Service Cloud v2
- SAP Sales Cloud v2
Reproducing the Issue
- Open one instance (e.g. Open a Lead)
- Change a field (e.g. Status)
- Warning message 'Cannot update status code due to restrictions set by SAP or your administrator' and the value is not changed.
Cause
The different values in before image and current image for the attribute/field which is marked as not updatable while calling property validator.
The property validation is not success.
Resolution
- Go to Settings > Extensibility Administration > related entity Service (E.g. LEAD) > Field Attributes
- The field (e.g. Status) is disabled for creation and update.
- Enable the relate property.
----------------------------------------
- Go to Settings > Extensibility Administration > related entity Service (E.g. LEAD) > Dynamic Properties
- Open the Dynamic Property
- You could find the field (e.g. Status) is disabled for creation and update.
- Change the condition or disable the related Dynamic Property.
Keywords
Cannot update XXX due to restrictions set by SAP or your administrator , KBA , CEC-CRM-CZM , Customization for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0