Symptom
Visibility of standard field Reason Code on Lead header is not working for all leads.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log in C4C.
- Go to Sales Woc.
- Open Leads OWL.
- Open any lead with a status different from Rejected or Accepted.
- Check if the field Reason Code is present in the UI.
Cause
The leads which are not in the status 'Accepted' or 'Rejected'. Only leads with the mentioned status can have a reason code displayed.
Resolution
This is the current system behavior, the 'Reason Code' field is only visible for leads with the status 'Accepted' or 'Rejected'. For other statuses, the field is not available.
Keywords
C4C; Cloud for Customer; Reason Code; Field visibility; Lead status; Accepted; Rejected; Field not visible; Conditional field; Status restriction , KBA , AP-RC-UIF , C4C UI Framework , Problem