SAP Knowledge Base Article - Public

3609460 - Unable to Edit Custom Field at Item Level in Manage Billing Document App

Symptom

  • The user is unable to edit a custom field at the item level in the "Manage Billing Document" app
  • A custom field has been created using the Custom Fields app, and the relevant UI and Reports option for Billing Document Item has been enabled. However, the custom field is not editable at the item level in the "Manage Billing Document" app

Environment

SAP S/4HANA Cloud Public Edition

Cause

It's working as designed, When using this app "Manage Billing document" to view a single billing document in detail, business users can edit custom fields on billing document level, but not on item level.

Resolution

All fields that are shown on item level are read-only.

To edit custom fields on item level, open the "Change Billing Documents" app. and go to the custom fields tab in the item details. 

For more info, refer the below help doc

https://help.sap.com/docs/SAP_S4HANA_CLOUD/a376cd9ea00d476b96f18dea1247e6a5/30f3db567e662e7be10000000a44147b.html?locale=en-US

Keywords

SAP S/4HANA Cloud Public Edition, custom fields, billing document, Sales: Billing Document Item, item level, document level, adapt filters, User Interfaces, Billing document items, Manage Billing Document , KBA , SD-FIO-BIL-2CL , Fiori UIs for Billing (Public Cloud) , How To

Product

SAP S/4HANA Cloud Public Edition all versions