SAP Knowledge Base Article - Public

3609554 - Reverting a Product Status to Active does not also change the Sale Status

Symptom

When the Product Status is changed from Active to Blocked or Obsolete, the corresponding Sales Status at the Sales Organization level is automatically updated to Blocked/Obsolete as well. However, when the Product Status is reverted back to Active, the Sales Status does not follow the same behavior and remains Blocked/Obsolete.

Environment

  • SAP Sales Cloud Version 2
  • SAP Sales and Service Cloud Version 2

Reproducing the Issue

  1. Open any Product with status set to Active.
  2. Change the Product Status to Blocked or Obsolete.
  3. Notice that the Sales Status is automatically updated to Blocked/Obsolete.
  4. Change the Product Status back to Active.
  5. Observe that the Sales Status does not revert and remains Blocked/Obsolete.

Cause

The system does not automatically determine that a Product set to Active is permitted for sale across all Sales Data combinations. Even if the Product Status is reverted to Active, the system requires explicit user confirmation for each Sales Organization and Distribution Channel. Therefore, the Sales Status is not automatically reset.

Resolution

This behavior is working as designed. If the Product should be sellable again for a specific Sales Organization, the user must manually update the Sales Status within the corresponding Sales Data entry.

Keywords

product sales status, product status, active product, blocked product, obsolete, sales status , KBA , CEC-CRM-PRD , Product for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0