SAP Knowledge Base Article - Public

3609773 - Error: Instance with the same key () already exists in Self-Services Time Sheet

Symptom

  • An error occurs when a service agent tries to record times via the self-services.
  • The error message "Instance with the same key () already exists" is displayed when changing the view from "Worklist" to "Day" in the "Edit Time Sheet" section.

Environment

SAP Business ByDesign

Reproducing the Issue

As the affected User:

  1. Navigate to the Home work center.
  2. Open the Self-Services Overview view.
  3. Enter Edit Time Sheet.
  4. Change the view filter from "Worklist" to "Day" 
  5. Error appears: Instance with the same key () already exists.

Cause

There may be duplicate time recording entries in the backend.

Resolution

Create a case with technical support to have the duplicate entries removed.

Keywords

KBA , SRD-HR-TLM , Time and Labour Management , Problem

Product

SAP Business ByDesign all versions