Symptom
- An error occurs when a service agent tries to record times via the self-services.
- The error message "Instance with the same key () already exists" is displayed when changing the view from "Worklist" to "Day" in the "Edit Time Sheet" section.
Environment
SAP Business ByDesign
Reproducing the Issue
As the affected User:
- Navigate to the Home work center.
- Open the Self-Services Overview view.
- Enter Edit Time Sheet.
- Change the view filter from "Worklist" to "Day"
- Error appears: Instance with the same key () already exists.
Cause
There may be duplicate time recording entries in the backend.
Resolution
Create a case with technical support to have the duplicate entries removed.
Keywords
KBA , SRD-HR-TLM , Time and Labour Management , Problem
Product
SAP Business ByDesign all versions