Symptom
A sales order template file uploads successfully in the "Import Sales Order" app. However, after executing the import, the creation status of the sales orders shows as failed, and the following error appears in the application log details.
Error Description: An exception was raised
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Upload the template file using the "Import Sales Orders" app.
- Upon preview, the message "You can now import the sales orders" appears.
- Click the "Import" button, and then click the "View Import" button to review the import results.
- The "Creation Status" indicates failure.
- An error with the description "An exception was raised" is shown in the log details.
Cause
One of the possible reasons is a missing application job authorization. When adding the SAP_SD_BC_SO_IMPORT_PC(Sales - Sales Order Import) business catalog to an assigned business role, F8149_TRAN(Schedule Import for Sales Orders) should be activated. Once F8149_TRAN (Schedule Import for Sales Orders) is deactivated, the error "An exception was raised" occurs due to missing authorization for scheduling import jobs.
An exception was raised
Resolution
- Option 1: Remove the SAP_SD_BC_SO_IMPORT_PC (Sales - Sales Order Import) business catalog from the assigned business role and then add it again.
- Option 2: Activate F8149_TRAN(Schedule Import for Sales Orders) according to the following screenshot.
See Also
Keywords
Import Sales Orders, Import Sales Documents, An exception was raised, exception raised, import authorization, SAP_SD_BC_SO_IMPORT_PC, SAP_SD_BC_SLSDOC_IMPORT_PC, F6192_TRAN, F8149_TRAN, Sales Order Import, Sales Document Import. , KBA , SD-SLS-IMP-SPR-2CL , Sales Document Import from Spreadsheet (Public Cloud) , Problem
Product
Attachments
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