Symptom
When going to the Latest Benefits Overview section for an employee, an application error is received with the below details:
An application error occurred. Please try again later, or copy the below error information and send it to your support group if the issue keeps occurring.
internalMessage=Failed to retrieve user’s available benefits.
errorMessage=lnternal error
name=Error
code=lnternalError
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Log into environment
- Go to an example user's profile
- Go to the 'Benefits' section and select 'Go to Benefits Overview'
- Receive error on load of the Benefits Overview
Cause
For some users, if they have more than 4 eligible benefits for which they can enroll, the Benefits Overview API throws the error. This error only occurs on the Benefits Overview main page, where the 'Eligible To Enroll' section is restricted to showing up to 4 benefits (this issue does not occur on the 'View All' view).
Resolution
This issue has been investigated and will be fully resolved with BEN-19808 in 2H 2025. In the meantime, it will be patched with PTCH-46995 in 2505p6, which should be implemented in Preview on May 27th, 2025 and Production on May 29th, 2025.
Keywords
benefit, benefits, overview, benefits overview, application, error, application error, Failed to retrieve user’s available benefits, lnternal error, lnternalError, INC12780894 , KBA , LOD-SF-EC-GBF , Global Benefits , Bug Filed