SAP Knowledge Base Article - Public

3610613 - How to Display Custom Fields in the "My Inbox" app in SAP S/4HANA Cloud Public Edition?

Symptom

  • During the enhancement of the workflow approval process, additional custom fields are required to be visible in the Workflow/Inbox app during the approval of Sales Contracts.
  • An attempt to use "Adapt UI" to add these fields is unsuccessful due to the Workflow/Inbox app ID mismatch with the actual target application, "Manage Sales Contracts - Version 2".
  • Consequently, changes cannot be made or saved to the layered repository.

Environment

SAP S/4HANA Cloud Public Edition

Cause

Currently data in the "My Inbox (for sales order or sales contract)" is from the Version 1 app, e.g., "Manage Sales Orders", "Manage Sales Contracts", etc. 

Resolution

  • Add the custom field via "Adpat UI" in the Version 1 apps, e.g., "Manage Sales Orders", "Manage Sales Contracts", etc. Then, the custom field will be visible in the "My Inbox" app.
  • Raise a feature request requiring to have custom fields in the Version 2 apps visible in the "My Inbox" app, following KBA 2963059 - How to Submit Feature Requests for SAP S/4HANA Cloud Product

Keywords

Workflow/Inbox app, Adapt UI, custom fields, app ID mismatch, SAP S/4HANA Cloud Public Edition, Sales Contract task, Salesperson, CRM Case No. , KBA , SD-SLS-WFL , Approval Workflows , How To

Product

SAP S/4HANA Cloud Public Edition all versions