SAP Knowledge Base Article - Public

3611414 - Effective date not showing in User's time zone

Symptom

If User time zone contains large hours discrepancy of system time zone, it is noted that Date Created and Effective Date on Quote level are different. 

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  • Set a User Time Zone to one that is one day ahead of system's default time zone
  • Create a Quote
  • Check that Quote Date Created and Effective Date are not the same.

Cause

Missing Functionality.

Resolution

  • Issue:
    • Effective Date do not take into consideration Time Zone 
  • Cause:
    • Effective Date is set as predefined date format, and is initially set by system default
    • Discrepancy arise when user has different time zone with large hours gap
  • Workaround:
    • Manually change Effective Date after quote creation
    • Manipulate Effective Date by using scripting (Quote | SAP Help Portal
      • Keep in mind that the script triggers a whole quote reconfiguration
  • Raise/Vote for enhancement request on Customer Influence Portal.

See Also

Keywords

Effective Date, Time Zone, User Page, System, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Product Enhancement

Product

SAP CPQ 2024