SAP Knowledge Base Article - Public

3611424 - Error "Enter a country/region." when trying to delete the Country

Symptom

Error "Enter a country/region." when trying to remove the Country from Account's header. However, the Country is not set as mandatory in Settings. 

Environment

  • SAP Sales Cloud Version 2
  • SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to Accounts.
  2. Open any Account. 
  3. Expand the detailed view.
  4. Edit field Country and delete the value.
  5. Error "Enter a country/region." happens. 

Cause

There is a standard validation checking if Country is filled for a postal Address.

Meaning that, if an instance for the sub-entity "Account Address" exists, Country for this instance is mandatory.

Resolution

If you want to delete an Address (and therefore the Country), you have to choose the corresponding action in the Addresses list.

Keywords

Address , Country , Error , Delete , Remove , Header , Country/Region  , KBA , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0