Symptom
Task chain fails with error:
RUN_CHAIN - Failed (Consent Expired)
Environment
SAP Datasphere
Reproducing the Issue
UserB has sufficient permissions, including consent to run the affected scheduled task.
Same user is the owner of the schedule of the affected task. Task still fails.
Cause
It is possible that UserB was registered with different UserA’s email internally and once task chain is executed and consent is checked emails don't match.
Resolution
If UserB was once registered with a different user’s email on Users tab proceed with the following steps:
- UserB needs to logon to Datasphere;
- Revoke the consent;
- Re-assign the consent;
- Attempt again taskchain execution.
See Also
Help - Check Consent Expirations
Keywords
TaskChain, consent, forbidden, expired , KBA , DS-DI-SCH , Scheduling and Task Chains , Problem