Symptom
Records are missing in Sales Cloud Version 2 while replicating customer material info records from S4HANA using standard iflows
Environment
SAP Sales & Service Cloud V2 Integration with SAP S/4HANA
Cause
Unlike Cloud for Customer / V1, there is no dedicated entity for this information, its saved in the product entity against the products sales data.
Resolution
Customer part numbers are saved on the product under the sales data if you have sent it through Material Replication as well as Customer Material Info replication.
Once you open the product and open the details of sales area information - then you can see the customer part number in the details page.
Keywords
"Customer Material Info" "customerPartNumberS4ReplicationMessageIn" , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-DC , Data Connector for SAP Sales/Service Cloud , Problem