SAP Knowledge Base Article - Public

3613352 - onChange Business Rule not changing field to Mandatory via Quick Action and Joule

Symptom

  • onChange Business Rule not working when adding Contract End Date via Employee Central Quick Action and Joule.
  • When Regular/Temporary field is changed, Contract End date should become mandatory. This is not happening in Quick Action or Joule.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Employee Central

Reproducing the Issue

  1. On Employee Profile
  2. Actions
  3. Change Contract End Date (Quick Action Template)
  4. Change field Regular/Temporary to Temporary
  5. As per Business Rule, if Regular/Temporary field is set to Temporary, Contract End Date should become a mandatory field.
  6. See that Contract End Date remains as non-mandatory.

Cause

This is working as designed.

As per Differences Between Quick Actions and Self-Service Transactions | SAP Help Portal: "OnChange rules support changing field values but not field attributes. However, it is not possible to change fields from editable to read-only (or the reverse) using rules for fields included in the Quick Action." 

Resolution

In case this is important to your business, we encourage you to submit an idea for SAP SuccessFactors Products to have this functionality considered within future development cycles, please consider opening an enhancement request. For detailed steps on How to Submit Ideas for SAP SuccessFactors Products, please refer to KBA 2090228.

See Also

Keywords

business rule, contract end date, quick action, employee central, job info, mandatory field, regular/temporary, rule trace, onChange, attributes,  , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions