Symptom
When clicking "Inspection Lot" button to generate source inspection lot in Source Inspections - Worklist app, error message "Batch not specified in order" occurs, and there is no inspection lot generated.
Environment
S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to Source Inspections - Worklist app(QI07).
- Enter the selection parameters and execute, there will be red traffic lights for the purchasing document items in the result list.
- Click the red traffic light, there is an error message "Batch not specified in order".
- Click "Inspection Lot" button and then save, there is no response.
- Check whether the inspection lot is generated in Process Inspection Lots - Worklist(QA32), it is not generated.
Cause
The root cause of the issue is that the "Batch management" indicator is maintained in the material master, but batch number is not maintained in the purchase document. As a result, if executing Source Inspections - Worklist app without indicator "Inspect w/o batch", the error will occur and no inspection lot will be created for the purchase document.
Resolution
To create an inspection lot for a material with batch management, one of the following options can be used:
- Option 1: Maintain the batch information in the purchasing document. Execute Source Inspections - Worklist app without indicator "Inspect w/o batch".
- Option 2: Keep the batch field empty in the purchasing document. Execute Source Inspections - Worklist app with indicator "Inspect w/o batch".
Keywords
inspection lot, source inspection, batch management, material master, quality info record, QI07, QA32, Source Inspections - Worklist, purchasing document , KBA , QM-IM-IL-2CL , Inspection Lot Creation (Public Cloud) , Problem