SAP Knowledge Base Article - Public

3613418 - User can not login SuccessFactors instance due to incorrect locale setting

Symptom

  • Users was unable to log in SF instance. Upon login, an error popup window is displayed with error message "Failed to execute 'fetch' on 'Window': Failed to read the 'headers' property from 'RequestInit'"
  • The issue can be reproduced consistently even if browser cache is clear.

 

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Attempt to log in to SAP SuccessFactors Platform.
  2. Observe the login failure and error message window is displayed

Cause

The issue is caused by the user's incorrect locale setting in the DEFAULT_LOCALE field in user UDF. The DEFAULT_LOCALE field was updated by Basic Import. The locale was set to "English" or "Chinese" instead of the system-supported "en_US"or "zh_CN".

Resolution

  1. Export user data through Employee Export.
  2. Identify users with incorrect DEFAULT_LOCALE settings.
  3. Change the DEFAULT_LOCALE field to the standard language code "en_US"or "zh_CN".
  4. Update the user's DEFAULT_LOCALE field using Basic Import.
  5. Verify that users can log in successfully.

Keywords

login issue, locale setting, SAP SuccessFactors, missing definition, correlationId, Default_Locale, Failed to execute 'fetch' on 'Window', Failed to read the 'headers' property from 'RequestInit', language code, employee export, basic import , KBA , LOD-SF-PLT-LHOM , Latest Home Page , Problem

Product

SAP SuccessFactors HCM Suite all versions