Symptom
Employee received a notification (There was an error in processing your response to an approval. Please go here to try again.) from a workflow he is not an approver or participant as Contributor or CC.
Environment
SAP SuccessFactors Employee Central - Workflow
Reproducing the Issue
- Check the email received by the employee.
- Click on the link in the email received.
- It takes to the manage workflow requests page.
- Notice that the employee who received the email notification is not a participant to the workflow.
Cause
- The issue stem from a change in the approver after the initiation of the workflow.
- Workflow is triggered to custom manager. At the time of workflow initiation, the approver was A, but later the custom manager is changed to B. This change appears to have caused an issue with the approval card of the workflow. If you proxy as A, you will find the to-do with an error.
- The reason why employee who is not a participant of the workflow, is receiving the notification is because he is proxying as the old approver and trying to approve the workflow from the to-do card. As the approval is failing, the notification is being sent to whoever is proxying.
Resolution
- Refresh the To-do item using a check tool. More details can be found in this guide: Accessing Workflows | SAP Help Portal
- Approve the workflow via the manage workflow request page, provided the new approver has access to this page.
- If the approver doesn't have permission to the manage workflow request page, you can change the approver to an admin user as a workaround and approve the workflow.
See Also
Keywords
workflow, notification, error message, approval, approver change, sap successfactors, employee central, proxy, to-do item, manage workflow request page , KBA , LOD-SF-EC-WFL-RUT , Workflow Routing, Dynamic Roles & Groups , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem
Product
SAP SuccessFactors Employee Central 2505