Symptom
A Customer Return created via Web Service CustomerReturnNotificationBundleCreateRequest displays error "Party with role Employee Responsible missing", while the expected determination for Employee Responsible is "Logged on User".
Environment
SAP Business ByDesign
Reproducing the Issue
An XML Payload is sent through Web Service CustomerReturnNotificationBundleCreateRequest which does not include the the Employee Responsible in the XML. When the Customer Return is created, the Employee Responsible is missing.
Cause
The configuration maintained in "Involved Parties for Customer Returns" is trying to determine the Employee Responsible as the Logged on User, however, since the Web Service call is being made by a Technical User, which cannot be determined as the Employee Responsible.
In Business Configuration, we can check the configuration for determination of Involved Parties in Customer Returns:
- Go to the Business Configuration Work Center.
- Open the Overview.
- Find and Open Configuration Element "Involved Parties for Returns".
- Highlight the Party Role "Employee Responsible" and click the "Maintain Determinations" Button.
In the Determination Steps, you see that "Logged on User" would be determined. Because of this, the Employee Responsible in the returns is blank, and error "Party with role Employee Responsible missing" is raised.
Resolution
In order to avoid this issue, please either maintain an Employee Responsible in the XML Request, or change the configuration for "Involved Parties for Retuns" in a way that an Employee Responsible is always found instead of being determined as the Logged on User.
Keywords
KBA , AP-SLO-SO , Sales Order , How To