SAP Knowledge Base Article - Public

3614206 - Consistency check or activation fails due to inactive Business Configuration Set

Symptom

  • A consistency check or activation fails on a PDI solution due to inactive Business Configuration Set issues.
  • The Business Configuration Sets in question appear active in the SDK.

Environment

  • SAP Cloud for Customer
  • SAP Business ByDesign
  • SAP Cloud Application Studio

Reproducing the Issue

  1. Run a consistency check on a Pdi solution from the SDK.
  2. Errors such as below will be raised:
    a. Error during check in: Business Configuration Set.
    b. Issue occurred in the application component: AP-RC-BDS-BC.
    c. Runtime object is not up-to-date. Activate /BCSET1.bcc.
    d. Runtime object is not up-to-date. Activate /BCSET2.bcc.
    e. Consistency check in background failed. 

Cause

Inconsistency may occur after Business Configuration entity creation.

Resolution

  1. Re-activate all BC Sets mentioned in the error individually.
  2. Re-activate the BAC Element.
  3. Proceed with the assembly of the solution

Keywords


Business Configuration, inactive BC Set, SDK activation error, runtime object error, consistency check failure, Pdi solution, BAC element, SAP Cloud Application Studio, SAP Business ByDesign, SAP Cloud for Customer, AP-RC-BDS-BC, assembly failure, activation issue, BC entity creation inconsistency, solution assembly , KBA , AP-RC-BDS-BC , ByDesign Studio Business Configuration , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer core applications all versions