Symptom
- The above error (including misspelling of "application") occurs in the application log of "Adapt Integration Content for New Tenant"
- Mapping errors occur in the Web Service Message Monitor after running this job
Environment
- SAP Cloud for Customer
Reproducing the Issue
- Navigate to the C4C Administrator work center.
- Click General Settings.
- Click Integration and select 'Adapt Integration Content for New Tenant'.
- Click on the Application Log number, then select the Results tab to see the error.
Cause
A message (payload) from C4C has already been exchanged with an external system ID Mapping created manually with the new system. 'Adapt Integration Content for New Tenant' can only be run in a tenant for a Business system for which no message exchange has taken place to avoid any data inconsistency.
Resolution
- Delete all ID mapping created and run the report again.
- If messages that creates BTD references have been exchanged, then it will be necessary to request for a new tenant copy.
You can find more information about the functionality below:
https://blogs.sap.com/2016/03/16/tenant-refresh-adaptation-support-for-integration/
https://blogs.sap.com/2016/04/06/tenant-refresh-adaptation-support-for-integration-part-ii/
https://blogs.sap.com/2016/04/10/tenant-refresh-adaptation-support-for-integration-part-iii/
For conversion from ERP to S4, you can also check the following blog:
Keywords
KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem