SAP Knowledge Base Article - Public

3614264 - Right to Return "Position is required field and cannot be blank" - Employee Central

Symptom

  • Right to return not getting created for higher duty assignments, global assignment or leave of absence
  • In Admin Alerts -> Position Follow Up processes you see the following:
    • Position is a required field and cannot be blank.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Login in the system
  2. Add a GA or a HDP or a Leave of Absence
  3. Check that there is an error related to the Right to Return
  4. Go to the Admin Alerts -> Position Follow Up processes and check that 
    • Position is a required field and cannot be blank.

Cause

  • Position is set as mandatory in BCUI
  • When RTR is configured, the employee will be sent to another position and then the system will check that the previous Position will be without anyone. 

Resolution

When the customer choses to user RTR, then the Position field has to be set as non-required in BCUI.

Keywords

higher duty, right to return, position management, sap successfactors, employee central, event reason, follow-up processes, position field, error message, replication steps, public sector, UAT, non-production environment, RTR, GA, Leave of Absence, Position is a required field and cannot be blank, TIM, position, required, admin alerts, HDP, higher, duties, duty, higher duty, higher duties, global assignment, global, assignment , KBA , LOD-SF-EC-POS-RTR , Right to Return , LOD-SF-EC-TIM , Time Off , LOD-SF-EC-HDP , Higher Duties & Public Sector , LOD-SF-EC-GA , Global Assignment , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions