Symptom
The customer return is created with incorrect status, but no detailed error message shown on the document.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the sales orders work center.
- Go to the returns view.
- Open the return ABC, you can see there is red error on it shows that it is Incorrect document. but no error message at the bottom.
- Go to the Application and User Management - Business Task Management view.
- Search ABC, you find the task "Complete Customer Return ABC" with New status.
- Open the task, system says: Customer Return ABC has missing data and requires rework in order to be processed.
ABC represents the ID of the customer return.
Cause
The task is created if the employee is required to rework a customer return because of missing and/or incorrect data.
For example, the distribution channel or sales organization has not been maintained, or the employee responsible for entering the goods returned by the customer into the system has not assigned or incorrectly assigned a reference document (sales order or customer invoice) to a customer return item, or the selected values are not valid.
In this case, the document is inconsistent due to the assigned payment term is deleted in the system. So the value of payment term in the return is invalid, caused the document incorrect.
Resolution
To remove the inconsistency, the user need to create the payment term again in the system.
See Also
2921287 - No Open Tasks visible for Customer Returns
Keywords
customer return; inconsistent; incorrect; payment term; Customer Return has missing data and requires rework in order to be processed. , KBA , AP-SLO-SO , Sales Order , Problem