Symptom
A custom communication scenario is created to call the custom API. However, when creating the corresponding communication arrangement to call the API, the 'Inbound Service' appears blank.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Communication Arrangement app.
- Create the communication arrangement using the custom communication scenario.
- Navigate to the Inbound Services tab.
- Observe that the Inbound Services section is blank.
Cause
The external API scenario based custom CDS view is not included as an 'Inbound Service' in the custom communication scenario, which leads to the 'Inbound Service' appearing blank in the communication arrangement.
Resolution
To resolve the issue, add the external API scenario based custom CDS view to the 'Inbound Services' section of the custom communication scenario by following these steps:
- Open the Custom Communication Scenarios app.
- Search for the custom communication scenario (e.g., YY1_XX_API).
- Click on Edit.
- Navigate to the 'Inbound Services' tab and click Add.
- Select the custom CDS view created with the external API scenario.
- Click Save to apply the changes.
See Also
For further guidance, refer to the detailed steps available in the SAP Help Portal - Exposing a Custom CDS View as External API | SAP Help Portal
Keywords
communication arrangement, custom external API, inbound service, blank, custom CDS view, sap s/4hana cloud public edition, YY1_XXX_API, Custom Communication Scenario app, OData connectivity, Custom API, API, Inbound service, An external API scenario based on a custom CDS view is created to expose the Custom API , KBA , BC-SRV-APS-COM , Maintain Communication System and Arrangement , Problem