SAP Knowledge Base Article - Public

3614707 - Login issue after updating SSO certificate in Entra

Symptom

  • A login issue is experienced after manually generating and updating the new SSO certificate in Entra.
  • The following error message is received: "AADSTS76028: Signature algorithm used to sign data is not supported."

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

SAP SuccessFactors HCM Core

Reproducing the Issue

  1. Manually generate and update the new SSO certificate in Entra.
  2. Attempt to log in.
  3. Observe the error message: "AADSTS76028: Signature algorithm used to sign data is not supported.".

Cause

The issue is caused by the "Allow requests signed with RSA-SHA-1" option not being enabled in Entra.

Resolution

To resolve the issue, please follow the steps below:

  • Ensure the correct certificate is applied.

  • In Admin Center > Manage SAML SSO Settings, enable the "SSO certificate renewed" checkbox.

  • In Microsoft Entra, verify that the "Allow requests signed with RSA-SHA-1" option is enabled.

IMPORTANT: The above steps are provided as guidance only. Since this involves configuration on the Microsoft side, it falls outside of our ownership. For further assistance, please contact Microsoft Support directly. 

See Also

Keywords

login issue, sso certificate, entra, rsa-sha-1, sap successfactors, certificate renewal, manage saml sso settings, error message, signature algorithm , KBA , LOD-SF-PLT-SAM , SAML SSO First Time Setup , Problem

Product

SAP SuccessFactors Platform all versions