SAP Knowledge Base Article - Public

3614909 - How to modify the technical name of a local table in SAP Datasphere

Symptom

You are attempting to change the technical name of a local table in SAP Datasphere, but the field is disabled in the SAP Datasphere interface. The ALTER TABLE SQL statement results in an insufficient privileges error.

Environment

SAP Datasphere

Reproducing the Issue

  1. Try to change the business name on the deployed local table.
  2. The statement ALTER TABLE is not available  in the database explorer.

Cause

This is a product limitation.

Resolution

  1. Changing table names is not supported, as documented in the Columns section of the SAP Help Portal.
  2. Delete the column and add a new one with the desired name.

See Also

Columns | SAP Help Portal

Keywords

  • insufficient privilege
  • SQL statement
  • SAP HANA database explorer
  • grant alter
  • schema
  • error code 258
  • remote tables
, KBA , DS-DI-RT , Remote Tables , Problem

Product

SAP Datasphere all versions