Symptom
You are attempting to change the technical name of a local table in SAP Datasphere, but the field is disabled in the SAP Datasphere interface. The ALTER TABLE SQL statement results in an insufficient privileges error.
Environment
SAP Datasphere
Reproducing the Issue
- Try to change the business name on the deployed local table.
- The statement ALTER TABLE is not available in the database explorer.
Cause
This is a product limitation.
Resolution
- Changing table names is not supported, as documented in the Columns section of the SAP Help Portal.
- Delete the column and add a new one with the desired name.
See Also
Keywords
- insufficient privilege
- SQL statement
- SAP HANA database explorer
- grant alter
- schema
- error code 258
- remote tables
Product
SAP Datasphere all versions
SAP Knowledge Base Article - Public