Symptom
When a standard email template is used in the 'Send Email Notification' tool, tokens such as [<&STUD_ID>] or [<&TITLE>] are not replaced with actual values. Instead, the raw token text is displayed in the received email.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Login to Learning administration
- Search for any user > Go to user record page from the "Actions" area
- Click Send Notification
- Build the Email by specifying Email Address (a "From" email address is required), and select any email notification template (Ex: External verification reminder)
- Click "Send Notification" button
Cause
When the email notification template is triggered manually, it doesn't include the actual token information like user ID or username. The tokens are included when the email is automatically triggered due to an action being made.
Resolution
This behavior is part of the system design and not a defect.
When an email notification template is triggered manually using the 'Send Email Notification' tool, it is expected that the template content is sent as-is, without token replacement. This is because no underlying action or workflow is triggering the template to provide the necessary context for resolving tokens when you are sending the manual email notifications.
To understand which actions will trigger token replacement in the email template (e.g., for the External Verification Reminder email), refer to the Template ID to Receiver Map Template ID to Receiver Map | SAP Help Portal
See Also
Keywords
manual email notifications, user not receiving emails, system design, APM, email notification template, external verification reminder, send email notification, user, actions, trigger map, tokens , KBA , LOD-SF-LMS-NOT , Notifications , How To