SAP Knowledge Base Article - Public

3616210 - Not Able to Remove the Execution Block from the Service Order

Symptom

The execution block field is read only, you are not able to remove the block and process the open service order item.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Orders work center.
  2. Go to the Service order Processing view.
  3. Open the order ABC, we can see the message: document blocked for delivery. (ABC represents the ID of the service order)
  4. In General - More Information tab, the Execution Block field is filled with a value and it is read only status. Not able to remove the block.

Cause

There are multiple item lines in the service order. One item line is open status (release status=not released), the others are finished.

Since all the released lines are finished on invoicing, the document invoice status is Finished. You can check it in the Pricing and Invoicing tab - Invoicing sub tab.

Because the document invoice status is finished, the execution block is disabled and becomes read only. The user is not able to remove the execution block and further process the open item in the service order.

Resolution

This is the current designed behavior.

To remove the execution block and further process the open item line, the customer invoice need to be cancelled. This will revert the invoice status back from Finished status, and will re-open the Execution Block field in the service order. The user then can remove the block and further process the open line.

Keywords

service order; execution block; disable; grayed out; read only. , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions