Symptom
Automatic picking is not triggered when a return delivery is created, even though "Automatic Picking" is enabled in the shipping point configuration.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Create a return sales order is created using a return document type (e.g. CBAR).
- The system creates a return delivery (e.g., via delivery type LR2, RL, or LR).
- Shipping point has "Automatic Picking" enabled.
- However, after the return delivery is created, the Picked Quantity remains at 0.
Cause
Automatic picking requires both of the following to be true:
- The shipping point is configured with "Automatic Picking" enabled.
- The delivery type used in the return delivery also has "Automatic picking" enabled.
If the delivery type (e.g., LR2, RL, or LR) does not have the "Automatic picking" flag enabled, the process will not trigger picking automatically, even if the shipping point is set up correctly.
Resolution
Enable Automatic Picking in the relevant delivery type configuration:
- Open app: Configure Your Solution
- Navigate to SSCUI 102123 – Define Delivery Types
- Locate your return delivery type (e.g., LR2, RL, or LR)
- Click into the delivery type and scroll to the Document Content section
- Enable the checkbox for "Automatic picking"
- Save your changes
Note: This change applies to newly created deliveries after the configuration is updated.
See Also
Keywords
SAP S/4HANA Cloud Public Edition, Public Cloud, Shipping Point, LR2, Delivery Type, SSCUI 102123, Define Delivery Types, S/4HANA Cloud, Return Delivery, Auto Picking, SSCUI 102123, Delivery Type LR2, Picking Qty 0, Delivery not picked, Standard Returns, Returns Processing , KBA , SD-SLS-RE-2CL , Returns (Public Cloud) , Problem