Symptom
- Data Retention Management page is not loading, and it gives an error message
Error:
errorId=null, timestamp=null, errorMessage=Gateway Time-out, errorName=dwr.engine.http.504, reply=<HTML><HEAD><TITLE>Error</TITLE></HEAD><BODY>
An error occurred while processing your request.<p>
Reference #221.6b57b5c.1745349111.31a78ed8
<P>https://errors.edgesuite.net/221.6b57b5c.1745349111.31a78ed8</P>
</BODY></HTML>
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Login to instance
- Go to > Data Retention Management page
- The page is just loading and throw an error message:
errorId=null, timestamp=null, errorMessage=Gateway Time-out, errorName=dwr.engine.http.504, reply=<HTML><HEAD><TITLE>Error</TITLE></HEAD><BODY>
An error occurred while processing your request.<p>
Reference #221.6b57b5c.1745349111.31a78ed8
<P>https://errors.edgesuite.net/221.6b57b5c.1745349111.31a78ed8</P>
</BODY></HTML>
Cause
The root cause of the performance issue is the excessive number of purge rules that have been configured.
Resolution
Customer is advised to review these rules and delete any excessive purge rules that are no longer needed to avoid any performance issues.
Steps to be taken:
- Go to Data retention management page
- Click >More Actions -> Delete from UI (This will help improve the performance of loading this page)
See Also
Keywords
Data retention management, data retention page not loading, gateway timeout, purge rules, purge inactive user, sap SuccessFactors, performance issue, deprecated rules, manual data purge, excessive number of purge rules, Gateway Time-out , KBA , LOD-SF-PLT-DRM , Data Retention Management , Problem