Symptom
- There is an original record that cancelled / edited however, the newly created record has a counter value that was lower than the original record.
- The expectation is that the counter index value continues to increment by one whenever a new record is created.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Create a time entry in CATSDB table.
- Edit the originally created entry and save the data.
- Check if the "Counter" record value has incremented appropriately.
Cause
The counter is not configured to work incrementally; it is just taken from a Number Range Object.
Resolution
This is considered the standard system behaviour at this time.
See Also
Refer to: SAP Knowledge Base Article 3072643
2963059 - How to Submit Feature Requests for SAP S/4HANA Cloud Product
Keywords
counter, CATSDB, increment, time entry, SAP S/4HANA Cloud Public Edition, data management, customer data browser, number range object, status 60, record value , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem
Product
SAP S/4HANA Cloud Public Edition all versions