Symptom
The TodoEntryV2 API is not returning the completed tasks (status: 3) even though they are completed within the last 30 days.
Environment
SAP SuccessFactors Continuous Performance Management
Reproducing the Issue
- Use the TodoEntryV2 API to retrieve the list of todo tasks for
- Category: 59, Business Task: Complete Continuous Feedback Request Task,
- Product Area: Performance Management - Continuous Feedback,
- Category ID: CATEGORY_REQUEST_CONTINUOUS_FEEDBACK.
- Observe that the response does not include completed tasks.
Cause
For feedback requests in the To-Do entry (Category: 59), only statuses 2 and 4 (deleted) are supported—status 3 is not supported.
Resolution
When the logged-in user approves or declines the feedback request, the status will be set to 4.
This behavior aligns with how pending 'Feedback Requests' appear on the UI (To-Do Panel).
See Also
Keywords
feedback request, ToDoEntryV2, OData API Framework, category 59, CPM, status 3, not supported, expected behavior, todo panel, decline feedback, approve feedback, CATEGORY_REQUEST_CONTINUOUS_FEEDBACK, Complete Continuous Feedback Request Task , KBA , LOD-SF-CPM-API , Webservices, OData APIs , How To