Symptom
- Workflow notification is not triggering for CC role when no approvers are configured in the workflow.
- Notification is not sent when the CC role is configured for Role "Self" and the user is terminated in the past.
- If the user is terminated in the future, notification is sent.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Create a workflow and add only a CC Role of type "Role" and for user "Self". You can assign a custom template or leave with the standard configuration.
- Make a Termination for a user and select an effective date in the past.
- Workflow triggers as per Rule Trace, but no notification is received.
Cause
Email recipient was terminated in the past.
Resolution
System does not support triggering notifications for Inactive users. When the CC role type is Self and the user is terminated in the past, the notification cannot be sent, although there aren't errors on UI.
For future-dated terminations, notifications are normally received.
In the internal logs, error message is: "Email Recipient is either terminated or is an invalid user."
Note: for cases where the user is terminated but is not changed to inactive at the exact moment of the termination, like terminations done via API or workflows with approval steps, the user may receive a notification. However, if the termination date is in the past, we do not recommend having this configuration, as the notification would be received only when there's this gap in the HRIS Sync time.
See Also
Keywords
workflow, notification, cc role, sap successfactors, employee central, email template, approvers, termination, invalid user, Email Recipient is either terminated or is an invalid user , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-WFL-CUS , Custom Workflow Notifications , Problem