Symptom
Service confirmation ABC was created from the Goods and Service Receipt DEF. After the Goods and Service Receipt DEF is cancelled, the service confirmation is not cancelled accordingly. A process communication error is appearing in the document flow.
- It is the intercompany field service and repair scenario.
- ABC represents the ID of the service confirmation.
- DEF represents the ID of the goods and service receipt.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Field Service and Repair - Service Confirmations view.
- Open the service confirmation ABC. it is Not Started status.
- In the document flow, we can see the Goods and Service Receipt DEF is cancelled, and a process communication error is displayed.
Cause
In Application and User Management - Process Communication Errors view, you are able to find the Process communication Error related.
- sending document: Goods and Service Receipt DEF
- receiving document: Service Confirmation ABC
- main error: Cancellation not possible; service confirmation item not found.
The error is due to the service confirmation ABC is with inconsistent status. When you editing the service confirmation ABC, system shows the error "Item **: Actual duration missing ". So the cancellation update failed to update the service confirmation due to the status.
Resolution
Firstly, remove the inconsistency from the service confirmation ABC by filling the missing actual duration value on the item line according to the error message.
Then, create a case to SAP technical support to restart the backend stuck message (in order to remove the process communication error and deploy the cancellation update).
Keywords
service confirmation; not cancelled; PCE; process communication error; Actual duration missing; intercompany. , KBA , SRD-CRM-SEO , Service Orders , Problem