Symptom
You have set up an approval process for a CRM document e.g. Customer Invoice but when you open the Customer Invoice and navigate to the Approval Process tab you don’t see the Approver. Instead, the following message is displayed:
An approver could not be determined. Either approval is not relevant, or the task is unassigned. Please contact your system administrator.
Environment
SAP Business ByDesign
Reproducing the Issue
This applies to multiple CRM documents. We will use the example of a Customer Invoice that was created via a New Manual Invoice Request.
- Go to the Customer Invoicing work center.
- Select the Invoice Documents view.
- Open Customer Invoice XYZ (XYZ represents the Invoice ID).
- Navigate to the Approval Process tab.
- No approver is displayed.
- Instead, the following message is displayed:
An approver could not be determined. Either approval is not relevant, or the task is unassigned. Please contact your system administrator.
Cause
The Approver in the Approval Process tab tab of the CRM Document can only be determined by the system once the Approval Process is triggered, an Approval Task is created by the system and the Task was assigned to a user.
If the Task was not created or the Task was created but could not be assigned to a user the mentioned message is displayed in the Approval Process tab of the document.
In our example of Customer Invoices, the Approval task is only created when the Invoice is released and the conditions of the Approval Process you set up for Customer Invoices are met.
There are 3 options that could cause this:
- The Invoice XYZ is in status Not Released. Therefore the Approval Process was not triggered so far and the Approval Status is Not Started.
- The Invoice XYZ is in status Released but the conditions are not met and the Approval Status is Approval not Necessary.
- The Invoice XYZ is in status Released, the conditions are met and the Approval Status is In Approval but no user could be assigned to the Approval Task.
Resolution
This is the expected system behavior.
If the Approval Task was created but could not be assigned to a user you can check this as follows:
- Go to the Application and User Management work center.
- Select the Business Task Management view.
- Select Unassigned Items.
- Select the respective Approval tasks.
- Click on the Determine Assignment tab.
- If the Task still cannot be assigned to a user, you can check the reason in the Application Log.
- In the General sub tab you can click on the hyperlink for the Application Log.
- In the Application Log under the General tab the system will display why the Task could not be assigned to the user.
You can either solve the issue reported in the Application Log or manually assigned the Task to a user via the Actions button and the Assign Items option.
Keywords
Approval Process, Approval Task, no user, no approver, approver missing, , KBA , AP-CI-CI , Customer Invoice , Problem