Symptom
Credit check is not performed for some of the sales order although the Automatic Credit Control is setup.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Activate credit management for customers.
- Maintain risk classes for customers.
- Create a sales order with 0.00 value for a customer whose Calc. Risk class field is not updated.
- Observe that the sales order is not blocked despite the credit limit being 0.00.
Cause
Below We will discuss some of the reasons for absence of credit check for business partner.
- The check rule assigned to the customer does not perform the Static Check for Credit Exposure.
- For the Sales Order Type ex. "OR", automatic credit control is not set-up.
- Check the item category for sales order line items. In the configuration settings "Determine Active Receivables Per Item Category SSCUI ID: 102571" the item category is not configured as "Credit Active" checkbox is not ticked.
Resolution
- The check steps is defined in configuration environment in the configuration activity Define Checking Rules. Available Check Steps
- In the configuration environment the configuration activity "Set Credit Limit Checks for Sales Document Types" set the "Automatic Credit Control" and "Credit Group".
- Maintain the item category in the configuration settings "Determine Active Receivables Per Item Category SSCUI ID: 102571".Set the item category as "Credit Active" by ticking the checkbox.
- Set-up Automatic Credit Control for the credit segment and risk class in the configuration activity "Define Automatic Credit Control".
Keywords
credit check, sales order, calc risk class, credit limit, sap s/4hana cloud, public edition, item category, credit active, configuration settings, SSCUI ID 102571 , KBA , FIN-FSCM-CR-2CL , Credit Management (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions