SAP Knowledge Base Article - Public

3617109 - Unable to record time for users in SAP S/4HANA Cloud Public Edition

Symptom

Unable to record time for employees who have left the company and whose business users have been deleted

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Attempt to record time for an employee that has a deleted Business User.

Cause

Employment Status is inactive and Business User no longer exists so timesheet entries cannot be handled for a user that has left the company.

Resolution

Use the Workforce Timesheet | SAP Help Portal API to handle the entries of the user as a Business User is not required using this method: "Business user ID is not mandatory to create time entries."

See Also

Keywords

inactive employees, business users deleted, time recording, IAM lifecycle, Notify Missing Time, SAP S/4HANA Cloud Public Edition, Manage My Timesheet, workaround, employment period , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem

Product

SAP S/4HANA Cloud Public Edition all versions