Symptom
You noticed that when creating a new Employee, the Employee ID is not generated automatically.
Environment
- SAP Sales Cloud Version 2
- SAP Sales and Service Cloud Version 2
Reproducing the Issue
- Go to User menu.
- Select Settings > All settings.
- Search and open Employees.
- Click on Create new Employee.
- The "Employee ID" field is marked as mandatory and it is empty.
Cause
The system is working as designed. For Business Partners of type Employee, the Employee ID must always be assigned manually/externally.
Although there is a dedicated Number Range configured for the Business Partner ID of Employees, this configuration does not apply to the Employee ID.
Resolution
Please make sure that the Employee ID is assigned manually or through an external system during Employee creation.
Keywords
Employee ID, Number Range, Mandatory, Business Partner, Sales Cloud Version 2, CNS , KBA , CEC-CRM-EMP , Employee for SAP Sales/Service Cloud , How To