SAP Knowledge Base Article - Public

3617744 - My Inbox app is not loading in Mobile Start iOS

Symptom

  • My Inbox app is not loading in Mobile Start iOS
  • My Inbox shows blank screen in IOS device while loading via Mobile Start
    • Trace errors may show: Block a frame with origin
  • Cloud Issue on CORS or Block Content in My Inbox and Mobile Start in the cloud

Environment

S/4HANA Cloud Public Edition 2502 and others

Reproducing the Issue

  1. Login in SAP Mobile start app.
  2. Scan the BTP Fiori app link via settings on BTP workzone.
  3. Enter your credentials (Passcode, UserID and Password).
  4. Site opens, user is able to see all the apps assigned to the user.
  5. Clicked on myInbox tile, loads for a while and shows blank screen
  6. Try to open the app again, still Blank screen appears.
  7. This issue is seen while using a browser in iOS device (Safari).

Cause

Trace stated:  

  • Failed to load resource: the server responded with a status 404 ()
  • App-defined navigation mode is not valid - Fallback to URL Template's capability sap.ushell.ApplicationType
    - Block a frame with origin "https://<customer unique id>.launchpad.cfapps.ap10.hana.ondemand.com" from accessing a frame with origin "https://my<customer number>.s4hana.cloud.sap.com". Protocols, domains, and ports must match.

NOTE (Root Cause) : The issue tied to the origin domains above: "ondemand.com" and "cloud.sap" is marked that it should match.

Resolution

Follow the following recommendation steps in order:

  1. Switch the operation of your SAP Build Work Zone, Standard Edition subscription (including the Onboarding to SAP Mobile Start) to the SAP Common Super Domain (cloud.sap). The following (SAP HELP documentation) https://help.sap.com/docs/build-work-zone-standard-edition/sap-build-work-zone-standard-edition/using-super-common-domain?locale=en-US describes how to access your SAP Build Work Zone, standard edition site with the cloud.sap domain. Please note that the ondemand.com domain stays active and users are not redirected.
  2. Kindly ask your users to re-onboard Mobile Start via the QR Code shown on Work Zone Standard when it is being accessed via its cloud.sap domain. Alternative you can push the required configuration to managed devices using an MDM solution.  See documentation: https://help.sap.com/docs/mobile-start/mobile-start-administration-guide/mobile-device-management-mdm?locale=en-US
  3. Make sure that all you integrated Cloud Content Providers are operated under the same common super domain. This is also stated in the documentation (https://help.sap.com/docs/build-work-zone-standard-edition/sap-build-work-zone-standard-edition/content-providers-cloud-solutions?locale=en-US) of SAP Build Work Zone, standard edition: "For integrating content from cloud solutions, all systems must operate under the same domain."

Keywords

Mobile-Start iOS, My Inbox Mobile-Start, My Inbox not working IOS, My Inbox IOS, My Inbox Safari, My Inbox Block a frame with origin, CORS cloud domain, Work zone standard edition, work zone common domain, cloud content providers , KBA , MOB-APP-SMS , SAP Mobile Start , EP-WZ-MOB-IOS , Work Zone Mobile Client IOS , EP-WZ-MOB , Work Zone Mobile Client , Problem

Product

SAP S/4HANA Cloud Public Edition 2502