Symptom
- All offboarding email templates are not being sent to offboardee
Environment
SAP Successfactors Onboarding
Reproducing the Issue
- Go to email services
- Go to Manage Email Templates
- Enable the (OFB) Offboarding Cancelled Template, with offboardee as recipient in the Onboarding Role-Based Recipient Builder
- Go to the offboarding dashboard
- Cancel an offboardee
- Go to email services
- See that the email has not been sent
Issue is happening for all offboarding email templates.
Cause
- As offboarding emails are internal emails, these emails can only be sent to email addresses of email type: business
- If another email type is set as primary such as personal, then the email will not send
Resolution
- Go to the employee profile of the user who is not receiving the email
- Go to contact information
- Click the edit option
- Set the business email as primary
- Save
- Test again
- See that email has been sent to the user
Keywords
Email, Offboarding email, email template, email services, Recipient , KBA , LOD-SF-OBX-EML , Notifications , LOD-SF-OBX-OFP , Offboarding 2.0 , Problem
Product
SAP SuccessFactors Onboarding