Symptom
The update for the business role is stuck in the "In Progress" status.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Administration Work Center.
- Go to Business Role View.
- In the dropdown, select All Business Role.
- In the search field, insert ABC (where ABC refers to the business role ID).
- Click on the Business Role ABC.
- Click on View All.
- Go to the tab Assigned Business User.
- Click on Assigned Users Button.
- Click on Update Users.
The users remain with the status "In Progress".
Cause
This is due to a system limitation, where business role updates are optimized for a user base of approximately 50 to 100 users. When exceeding this threshold, the update process gets stuck in the 'In Progress' status.
When the threshold is exceeded, the background job takes a long time to complete generating a timeout dump to be raised in the backend of the system.
Resolution
We recommend limiting the number of users assigned to the business role to a maximum of 100. This ensures the Update Assigned Users function operates effectively.
Furthermore, as an alternative option the below steps can be performed to update the users access rights in bulk.
- Go to Administration Work Center.
- Go to Business User View.
- Click on Update Access Rights.
- Click on Update All Users.
This will update the access rights of all users in the system, without the mentioned timeout limitation.
See Also
Keywords
update, business role, in progress, stuck, system limitation, identity & access management, role updates, assigned users, batch update , KBA , SRD-CC-IAM , Identity & Access Management , Bug Filed